eu

  1. EU Vita Owners: Space Invaders Extreme Is A 3.15 VHBL Exploit

    Submitted by Christopher Groux; Today! Wololo has been hyping another VHBL exploit for some time now, and today it's finally here. As long as you have an account for the EU/AUS PSN, be sure to pick up Space Invaders Extreme. With it, users on 3.15 firmware will soon be able to run a decent...
Üst